小编典典

如何解决java.lang.NoClassDefFoundError:Java 9中的javax / xml / bind / JAXBException?

java JAXBException

我有一些使用JAXB API类的代码,这些类作为Java 6/7/8中JDK的一部分提供。当我使用Java 9运行相同的代码时,在运行时出现错误,指示找不到JAXB类。

自Java 6以来,JAXB类已经作为JDK的一部分提供了,那么Java 9为什么不能再找到这些类?


阅读 467

收藏
2020-01-10

共1个答案

小编典典

JAXB API被认为是Java EE API,因此不再包含在Java SE 9的默认类路径中。在Java 11中,它们已从JDK中完全删除。

Java 9引入了模块的概念,默认情况下,java.se聚合模块可在类路径(或更确切地说,模块路径)上使用。正如其名称所暗示的,java.se汇聚模块并没有包括那些与Java 6/7/8传统上捆绑了Java EE的API。

幸运的是,JDK 6/7/8中提供的这些Java EE API仍在JDK中,但默认情况下它们不在类路径中。以下模块提供了额外的Java EE API:

java.activation
java.corba
java.transaction
java.xml.bind  << This one contains the JAXB APIs
java.xml.ws
java.xml.ws.annotation

快速而肮脏的解决方案:(仅JDK 9/10)

要使JAXB API在运行时可用,请指定以下命令行选项:

--add-modules java.xml.bind

但是我仍然需要这个才能与Java 8一起使用!!!

如果尝试--add-modules使用较旧的JDK进行指定,则该选项会崩溃,因为这是无法识别的选项。我建议两种选择之一:

  1. 你可以使用JDK_JAVA_OPTIONS环境变量设置任何仅Java 9+的选项。Java 9+ 的启动器会自动读取此环境变量java。
  2. 你可以添加-XX:+IgnoreUnrecognizedVMOptions来使JVM静默忽略无法识别的选项,而不是崩溃。但是要当心!JVM将不再为你验证你使用的任何其他命令行参数。该选项与Oracle / OpenJDK以及IBM JDK(自JDK 8sr4起)一起使用。

备用快速解决方案:(仅JDK 9/10)

请注意,你可以通过指定--add-modules java.se.ee选项在运行时使上述所有Java EE模块可用。该java.se.ee模块是一个聚合模块,其中包括java.se.ee上述Java EE API模块。请注意,这不适用于Java 11,因为java.se.ee已在Java 11中删除。

正确的长期解决方案:(JDK 9和更高版本)

上面列出的Java EE API模块均已标记,@Deprecated(forRemoval=true)因为它们计划在Java 11中删除。因此,该–add-module方法将无法在Java 11中直接使用。

在Java 11及更高版本中,你需要做的是在类路径或模块路径上包含你自己的Java EE API副本。例如,你可以像这样将JAX-B API添加为Maven依赖项:

<!-- API, java.xml.bind module -->
<dependency>
    <groupId>jakarta.xml.bind</groupId>
    <artifactId>jakarta.xml.bind-api</artifactId>
    <version>2.3.2</version>
</dependency>

<!-- Runtime, com.sun.xml.bind module -->
<dependency>
    <groupId>org.glassfish.jaxb</groupId>
    <artifactId>jaxb-runtime</artifactId>
    <version>2.3.2</version>
</dependency>

有关JAXB的更多详细信息,请参见JAXB参考实现页面

有关Java模块化的完整详细信息,请参见JEP 261:模块系统

对于Gradle或Android Studio开发人员:(JDK 9及更高版本)

将以下依赖项添加到build.gradle文件中:

dependencies {
    // JAX-B dependencies for JDK 9+
    implementation "jakarta.xml.bind:jakarta.xml.bind-api:2.3.2"
    implementation "org.glassfish.jaxb:jaxb-runtime:2.3.2"
}

2020-01-10

回答这个问题

Nothing to preview